Results 1 to 5 of 5

Thread: Find in files doesn’t appaer to look into “Tests” directories

  1. #1

    Find in files doesn’t appaer to look into “Tests” directories

    It appears that "Find in files" (the one that appears on the bottom) is not recursing into directories names Tests. Maybe I'm just doing something wrong, but I don't see any option that would cause this to happen.
    I had random searches that didn't produce results, despite there being matches. Upon investigation it seems it just doesn't look into certain directories.
    This is a git repository, but these directories are not marked in any way (they're special to our build scripts only).
    I've removed the Filter as well and it still doesn't search in those folders.

  2. #2

    Find in files doesn’t appaer to look into “Tests” directories

    It instead appears to only be looking 2-levels deep, since if I search from a folder higher it doesn't find any of my source files at all, not just the Tests ones. The Tests folder just happens to be a deeper folder than usual.
    Is this an option somewhere to restrict search depth?

  3. #3

    Find in files doesn’t appaer to look into “Tests” directories

    The search depth will be far more than 2, it sounds like that's correlation - not causation.
    Are you sure you don't have the folder in your Project excludes?
    Is the folder in question under a symlink by any chance?

  4. #4

    Find in files doesn’t appaer to look into “Tests” directories

    I have no project file (not a Komodo project, nor a Komodo recognized one that is).
    These are not symlinked directories. The main directory is ssh mounted (but I'm guessing Komodo doesn't care about that).

  5. #5

    Find in files doesn’t appaer to look into “Tests” directories

    It shouldn't care, but it's possible that the ssh filesystem you use is throwing Komodo off. Could you reproduce the issue on a local partition?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •