Results 1 to 5 of 5

Thread: Enable HTML syntax checking?

  1. #1

    Enable HTML syntax checking?

    I've mentioned before that I really like how Komodo detects inconsistent line endings and puts little squiggles under the offending lines. After I fix the error, I get a little check mark in the bottom, right-hand corner. Excellent.
    I'm testing editing of XHTML5. The editor is very responsive. The HTML tag and attribute suggestions are smooth, and the auto-tag-closing functionality is slick. I like it.
    But I don't understand the syntax checking. I enter the following line:
    <p>This is a <code>good test.</p>I expect to get some sort of error because there is no closing </code> tag. But the syntax checker does not complain. The little checkmark remains in the status window, as if everything is code.
    I installed the KLint extension, but I didn't see any difference.
    How do I enable HTML syntax checking?

  2. #2

    Enable HTML syntax checking?

    by default komodo only shows errors only, to enable it to show warnings you go to yourpreferences > Syntax Checking. Select the html language you got here a select "error level:" if you set this one to" errors and warnings" you will get lint results on above errors

  3. #3

    Enable HTML syntax checking?

    Unfortunately I don't have that option, as I had to turn off HTML Tidy because somehow Komodo was using a really out of date version. More unfortunately is that @nathanr doesn't know when he'll be able to fix this bug (Issue #944
    ). So one bug is having a cascading effect with other issues...

  4. #4

    Enable HTML syntax checking?

    There's a milestone for that. I guess it will be fixed in 9.3.3

  5. #5

    Enable HTML syntax checking?

    I guess that 9.3.2 will be released very soon, I don't see any issues opened for 9.3.2 milestone and new issues are in 9.3.3 milestone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts